Radiator

by Joe B, Saturday, August 22, 2015, 18:10 (640 days ago)

I have an overflow tank with my radiator and I am a little confused. After I run the truck for a while the antifreeze flows into the overflow the way it should. The problem is after the truck cools down it seems to pull more antifreeze than it should. I fill the radiator to the bottom of the neck and after it cools down the level is up to the top of the neck. If I fill it to the top of the neck it seems to still pull more from the overflow tank then it should because there are drops of antifreeze between the fins. I had a pressure test down at a radiator shop on Monday and it held pressure and check out good. What am I doing wrong?

Radiator

by Dspreeman ⌂ @, Saginaw, Michigan, Saturday, August 29, 2015, 16:52 (633 days ago) @ Joe B

Don't know a lot about your problem.....
But as we now know ...nobody uses this site.

--
Don S.
PhotoBucket pics.
http://s1007.photobucket.com/user/rockbasses/library/47%20Studebaker%20M15a?sort=3&...

Radiator

by Joe.B, Saturday, August 29, 2015, 20:49 (633 days ago) @ Dspreeman

I know two fools that do, you and some other guy. What is his name again?

Radiator

by RonC, Sunday, August 30, 2015, 08:49 (632 days ago) @ Joe.B

My overflow works good. Rad cold water level to the top and overflow tank with only enough fluid to be even with the top of the water return stand pipe in the bottom of the overflow tank. This way it can not pull more fluid than it released to the tank.

Radiator

by Joe.b, Sunday, August 30, 2015, 14:27 (632 days ago) @ RonC

Open the hood today and everything seemed to be working the way it should. Maybe an air pocket or things needed to settle themselves. After 5 years of radiator leaks it seems to have stopped.

RSS Feed of thread